CVE-2018-19872

NameCVE-2018-19872
DescriptionAn issue was discovered in Qt 5.11. A malformed PPM image causes a division by zero and a crash in qppmhandler.cpp.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qt4-x11 (PTS)jessie4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1vulnerable
jessie (security)4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u2vulnerable
stretch4:4.8.7+dfsg-11vulnerable
buster4:4.8.7+dfsg-18fixed
bullseye, sid4:4.8.7+dfsg-19fixed
qtbase-opensource-src (PTS)jessie5.3.2+dfsg-4+deb8u2vulnerable
jessie (security)5.3.2+dfsg-4+deb8u3vulnerable
stretch (security), stretch5.7.1+dfsg-3+deb9u1vulnerable
buster5.11.3+dfsg1-1fixed
bullseye5.11.3+dfsg1-2fixed
sid5.11.3+dfsg1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qt4-x11source(unstable)4:4.8.7+dfsg-18medium
qtbase-opensource-srcsource(unstable)5.11.2+dfsg-3low

Notes

[stretch] - qtbase-opensource-src <no-dsa> (Minor issue)
[jessie] - qtbase-opensource-src <no-dsa> (Minor issue)
[stretch] - qt4-x11 <no-dsa> (Minor issue)
[jessie] - qt4-x11 <no-dsa> (Minor issue)
https://bugreports.qt.io/browse/QTBUG-69449
qt4-x11: POC doesn't crash on neither jessie nor stretch, it's possibly incomplete; patch applies though.

Search for package or bug name: Reporting problems