CVE-2018-19873

NameCVE-2018-19873
DescriptionAn issue was discovered in Qt before 5.11.3. QBmpHandler has a buffer overflow via BMP data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1627-1, DLA-1786-1, DLA-2377-1, DSA-4374-1
NVD severityhigh
Debian Bugs923003

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qt4-x11 (PTS)stretch4:4.8.7+dfsg-11vulnerable
stretch (security)4:4.8.7+dfsg-11+deb9u1fixed
buster4:4.8.7+dfsg-18+deb10u1fixed
qtbase-opensource-src (PTS)stretch5.7.1+dfsg-3+deb9u2fixed
stretch (security)5.7.1+dfsg-3+deb9u3fixed
buster5.11.3+dfsg1-1+deb10u4fixed
buster (security)5.11.3+dfsg1-1+deb10u3fixed
bullseye, sid5.15.1+dfsg-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qt4-x11sourcejessie4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u2DLA-1786-1
qt4-x11sourcestretch4:4.8.7+dfsg-11+deb9u1DLA-2377-1
qt4-x11source(unstable)4:4.8.7+dfsg-18low923003
qtbase-opensource-srcsourceexperimental5.11.3+dfsg-1
qtbase-opensource-srcsourcejessie5.3.2+dfsg-4+deb8u3DLA-1627-1
qtbase-opensource-srcsourcestretch5.7.1+dfsg-3+deb9u1DSA-4374-1
qtbase-opensource-srcsource(unstable)5.11.3+dfsg-2low

Notes

https://blog.qt.io/blog/2018/12/04/qt-5-11-3-released-important-security-updates/
https://codereview.qt-project.org/#/c/238749/
https://github.com/qt/qtbase/commit/621ab8ab59901cc3f9bd98be709929c9eac997a8

Search for package or bug name: Reporting problems