CVE-2018-19888

NameCVE-2018-19888
DescriptionAn invalid memory address dereference was discovered in the huffcode function (libfaac/huff2.c) in Freeware Advanced Audio Coder (FAAC) 1.29.9.2. The vulnerability causes a segmentation fault and application crash, which leads to denial of service in the HCB_ESC case.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs915763

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
faac (PTS)jessie/non-free1.28-6vulnerable
stretch/non-free1.28+cvs20151130-1vulnerable
buster/non-free1.29.9.2-2vulnerable
bullseye/non-free, sid/non-free1.30-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
faacsource(unstable)1.30-1unimportant915763

Notes

https://github.com/knik0/faac/issues/25
Negligable security impact, crash in CLI tool (builds a lib, but only internal)

Search for package or bug name: Reporting problems