CVE-2018-19889

NameCVE-2018-19889
DescriptionAn invalid memory address dereference was discovered in the huffcode function (libfaac/huff2.c) in Freeware Advanced Audio Coder (FAAC) 1.29.9.2. The vulnerability causes a segmentation fault and application crash, which leads to denial of service in the book 6 case.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs915763

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
faac (PTS)jessie/non-free1.28-6vulnerable
stretch/non-free1.28+cvs20151130-1vulnerable
buster/non-free, sid/non-free1.29.9.2-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
faacsource(unstable)(unfixed)915763

Notes

[stretch] - faac <no-dsa> (Non-free not supported)
[jessie] - faac <no-dsa> (Non-free not supported)
https://github.com/knik0/faac/issues/22

Search for package or bug name: Reporting problems