CVE-2018-1999023

NameCVE-2018-1999023
DescriptionThe Battle for Wesnoth Project version 1.7.0 through 1.14.3 contains a Code Injection vulnerability in the Lua scripting engine that can result in code execution outside the sandbox. This attack appear to be exploitable via Loading specially-crafted saved games, networked games, replays, and player content.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wesnoth-1.10 (PTS)jessie1:1.10.7-2+deb8u1vulnerable
wesnoth-1.12 (PTS)stretch1:1.12.6-1+deb9u1fixed
wesnoth-1.14 (PTS)buster, sid1:1.14.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wesnoth-1.10source(unstable)(unfixed)medium
wesnoth-1.10sourcejessie(unfixed)end-of-life
wesnoth-1.12source(unstable)(unfixed)medium
wesnoth-1.12sourcestretch1:1.12.6-1+deb9u1medium
wesnoth-1.14source(unstable)1:1.14.4-1medium

Notes

[jessie] - wesnoth-1.10 <end-of-life> (Games are not supported in Jessie)
http://www.openwall.com/lists/oss-security/2018/07/20/1
https://github.com/wesnoth/wesnoth/commit/d911268a783467842d38eae7ac1630f1fea41318 (1.14.x)

Search for package or bug name: Reporting problems