CVE-2018-20124

NameCVE-2018-20124
Descriptionhw/rdma/rdma_backend.c in QEMU allows guest OS users to trigger out-of-bounds access via a PvrdmaSqWqe ring element with a large num_sge value.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow (attack range: local)
Debian Bugs922461

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie1:2.1+dfsg-12+deb8u6fixed
jessie (security)1:2.1+dfsg-12+deb8u11fixed
stretch1:2.8+dfsg-6+deb9u5fixed
stretch (security)1:2.8+dfsg-6+deb9u7fixed
buster1:3.1+dfsg-8~deb10u1vulnerable
sid, bullseye1:3.1+dfsg-8vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)(unfixed)unimportant922461
qemusourcejessie(not affected)
qemusourcestretch(not affected)
qemu-kvmsource(unstable)(unfixed)low

Notes

[stretch] - qemu <not-affected> (Vulnerable code not present)
[jessie] - qemu <not-affected> (Vulnerable code not present)
https://lists.gnu.org/archive/html/qemu-devel/2018-12/msg02822.html
https://git.qemu.org/?p=qemu.git;a=commit;h=0e68373cc2b3a063ce067bc0cc3edaf370752890
PVRDMA support not enabled in the binary packages until 1:3.1+dfsg-3, disabled again in 1:3.1+dfsg-4
The issue is in PVRDMA support, cf. https://bugs.debian.org/922461#18

Search for package or bug name: Reporting problems