CVE-2018-20148

NameCVE-2018-20148
DescriptionIn WordPress before 4.9.9 and 5.x before 5.0.1, contributors could conduct PHP object injection attacks via crafted metadata in a wp.getMediaItem XMLRPC call. This is caused by mishandling of serialized data at phar:// URLs in the wp_get_attachment_thumb_file function in wp-includes/post.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1673-1, DSA-4401-1
NVD severityhigh (attack range: remote)
Debian Bugs916403

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)jessie4.1+dfsg-1+deb8u17vulnerable
jessie (security)4.1.25+dfsg-1+deb8u1fixed
stretch4.7.5+dfsg-2+deb9u4vulnerable
stretch (security)4.7.5+dfsg-2+deb9u5fixed
buster5.0.3+dfsg1-1fixed
sid5.1.1+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)5.0.1+dfsg1-1high916403
wordpresssourcejessie4.1.25+dfsg-1+deb8u1highDLA-1673-1
wordpresssourcestretch4.7.5+dfsg-2+deb9u5highDSA-4401-1

Notes

https://wordpress.org/news/2018/12/wordpress-5-0-1-security-release/

Search for package or bug name: Reporting problems