CVE-2018-20189

NameCVE-2018-20189
DescriptionIn GraphicsMagick 1.3.31, the ReadDIBImage function of coders/dib.c has a vulnerability allowing a crash and denial of service via a dib file that is crafted to appear with direct pixel values and also colormapping (which is not available beyond 8-bits/sample), and therefore lacks indexes initialization.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1619-1
NVD severitymedium (attack range: remote)
Debian Bugs916752

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)jessie1.3.20-3+deb8u2vulnerable
jessie (security)1.3.20-3+deb8u7fixed
stretch (security), stretch1.3.30+hg15796-1~deb9u2vulnerable
buster, sid1.4~hg15978-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksource(unstable)1.4~hg15873-1medium916752
graphicsmagicksourcejessie1.3.20-3+deb8u5mediumDLA-1619-1

Notes

http://hg.graphicsmagick.org/hg/GraphicsMagick/rev/648e2b406589
https://sourceforge.net/p/graphicsmagick/bugs/585/

Search for package or bug name: Reporting problems