CVE-2018-20217

NameCVE-2018-20217
DescriptionA Reachable Assertion issue was discovered in the KDC in MIT Kerberos 5 (aka krb5) before 1.17. If an attacker can obtain a krbtgt ticket using an older encryption type (single-DES, triple-DES, or RC4), the attacker can crash the KDC by making an S4U2Self request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1643-1
NVD severitylow
Debian Bugs917387

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
krb5 (PTS)jessie1.12.1+dfsg-19+deb8u4vulnerable
jessie (security)1.12.1+dfsg-19+deb8u5fixed
stretch1.15-1+deb9u1vulnerable
buster1.17-3fixed
bullseye, sid1.17-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
krb5source(unstable)1.16.2-1low917387
krb5sourcejessie1.12.1+dfsg-19+deb8u5DLA-1643-1

Notes

[stretch] - krb5 <no-dsa> (Minor issue)
http://krbdev.mit.edu/rt/Ticket/Display.html?id=8763
https://github.com/krb5/krb5/commit/5e6d1796106df8ba6bc1973ee0917c170d929086

Search for package or bug name: Reporting problems