CVE-2018-20337

NameCVE-2018-20337
DescriptionThere is a stack-based buffer overflow in the parse_makernote function of dcraw_common.cpp in LibRaw 0.19.1. Crafted input will lead to a denial of service or possibly unspecified other impact.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs917080

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libraw (PTS)jessie0.16.0-9+deb8u3fixed
jessie (security)0.16.0-9+deb8u4fixed
stretch (security), stretch0.17.2-6+deb9u1vulnerable
buster0.19.2-2fixed
bullseye, sid0.19.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
librawsource(unstable)0.19.2-1medium917080
librawsourcejessie(not affected)

Notes

[stretch] - libraw <no-dsa> (Minor issue)
[jessie] - libraw <not-affected> (Vulnerable code not present)
https://github.com/LibRaw/LibRaw/issues/192

Search for package or bug name: Reporting problems