CVE-2018-20340

NameCVE-2018-20340
DescriptionYubico libu2f-host 1.1.6 contains unchecked buffers in devs.c, which could enable a malicious token to exploit a buffer overflow. An attacker could use this to attempt to execute malicious code using a crafted USB device masquerading as a security token on a computer where the affected library is currently in use. It is not possible to perform this attack with a genuine YubiKey.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4389-1
NVD severitymedium (attack range: local)
Debian Bugs921726

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libu2f-host (PTS)stretch (security), stretch1.1.2-2+deb9u1fixed
buster1.1.9-1fixed
bullseye, sid1.1.10-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libu2f-hostsource(unstable)1.1.7-1medium921726
libu2f-hostsourcestretch1.1.2-2+deb9u1mediumDSA-4389-1

Notes

https://www.yubico.com/support/security-advisories/ysa-2019-01/
https://github.com/Yubico/libu2f-host/commit/f526546bb29f2ef704ae9850f0f4b41fea7b62a4
https://github.com/Yubico/libu2f-host/commit/e77a109f8cf60d9eafdf005ab5c851d5f576c01e

Search for package or bug name: Reporting problems