CVE-2018-20455

NameCVE-2018-20455
DescriptionIn radare2 prior to 3.1.1, the parseOperand function inside libr/asm/p/asm_x86_nz.c may allow attackers to cause a denial of service (application crash via a stack-based buffer overflow) by crafting an input file, a related issue to CVE-2018-20456.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
radare2 (PTS)jessie0.9.6-3.1+deb8u1fixed
stretch1.1.0+dfsg-5vulnerable
buster, sid3.2.1+dfsg-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
radare2source(unstable)3.1.2+dfsg-1low
radare2sourcejessie(not affected)

Notes

[stretch] - radare2 <no-dsa> (Minor issue)
[jessie] - radare2 <not-affected> (vulnerable code not present)
https://github.com/radare/radare2/commit/9b46d38dd3c4de6048a488b655c7319f845af185
https://github.com/radare/radare2/issues/12373

Search for package or bug name: Reporting problems