CVE-2018-20482

NameCVE-2018-20482
DescriptionGNU Tar through 1.30, when --sparse is used, mishandles file shrinkage during read access, which allows local users to cause a denial of service (infinite read loop in sparse_dump_region in sparse.c) by modifying a file that is supposed to be archived by a different user's process (e.g., a system backup running as root).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1623-1
NVD severitylow (attack range: local)
Debian Bugs917377

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tar (PTS)jessie1.27.1-2+deb8u1vulnerable
jessie (security)1.27.1-2+deb8u2fixed
stretch1.29b-1.1vulnerable
buster, sid1.30+dfsg-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tarsource(unstable)1.30+dfsg-3.1low917377
tarsourcejessie1.27.1-2+deb8u2lowDLA-1623-1

Notes

[stretch] - tar <no-dsa> (Minor issue)
https://utcc.utoronto.ca/~cks/space/blog/sysadmin/TarFindingTruncateBug
https://news.ycombinator.com/item?id=18745431
https://twitter.com/thatcks/status/1076166645708668928
https://lists.gnu.org/archive/html/bug-tar/2018-12/msg00023.html
Fixed by https://git.savannah.gnu.org/cgit/tar.git/commit/?id=c15c42c

Search for package or bug name: Reporting problems