CVE-2018-20506

NameCVE-2018-20506
DescriptionSQLite before 3.25.3, when the FTS3 extension is enabled, encounters an integer overflow (and resultant buffer overflow) for FTS3 queries in a "merge" operation that occurs after crafted changes to FTS3 shadow tables, allowing remote attackers to execute arbitrary code by leveraging the ability to run arbitrary SQL statements (such as in certain WebSQL use cases). This is a different vulnerability than CVE-2018-20346.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1613-1, DLA-2340-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sqlite3 (PTS)stretch3.16.2-5+deb9u1vulnerable
stretch (security)3.16.2-5+deb9u3fixed
buster3.27.2-3+deb10u1fixed
bullseye3.34.1-2fixed
sid3.34.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sqlite3sourcejessie3.8.7.1-1+deb8u3DLA-1613-1
sqlite3sourcestretch3.16.2-5+deb9u2DLA-2340-1
sqlite3source(unstable)3.25.3-1

Notes

https://sqlite.org/src/info/940f2adc8541a838

Search for package or bug name: Reporting problems