CVE-2018-20540

NameCVE-2018-20540
DescriptionThere is memory leak at liblas::Open (liblas/liblas.hpp) in libLAS 1.8.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs922459

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
liblas (PTS)jessie1.8.0-1vulnerable
stretch1.8.1-3vulnerable
buster, sid1.8.1-10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
liblassource(unstable)1.8.1-10medium922459

Notes

[stretch] - liblas <no-dsa> (Minor issue)
[jessie] - liblas <no-dsa> (Minor issue)
https://github.com/libLAS/libLAS/issues/158
https://github.com/libLAS/libLAS/commit/ba7346d349fb00b18d0c12e226ac3090eac25d7b

Search for package or bug name: Reporting problems