CVE-2018-20553

NameCVE-2018-20553
DescriptionTcpreplay before 4.3.1 has a heap-based buffer over-read in get_l2len in common/get.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs917574

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tcpreplay (PTS)jessie3.4.4-2+deb8u1vulnerable
stretch3.4.4-3vulnerable
buster4.3.1-1fixed
sid4.3.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tcpreplaysource(unstable)4.3.1-1low917574

Notes

[stretch] - tcpreplay <no-dsa> (Minor issue)
[jessie] - tcpreplay <no-dsa> (not used by any sponsor, hard to exploit)
https://github.com/appneta/tcpreplay/issues/530
https://github.com/appneta/tcpreplay/pull/532/commits/6b830a1640ca20528032c89a4fdd8291a4d2d8b2

Search for package or bug name: Reporting problems