CVE-2018-20615

NameCVE-2018-20615
DescriptionAn out-of-bounds read issue was discovered in the HTTP/2 protocol decoder in HAProxy 1.8.x and 1.9.x through 1.9.0 which can result in a crash. The processing of the PRIORITY flag in a HEADERS frame requires 5 extra bytes, and while these bytes are skipped, the total frame length was not re-checked to make sure they were present in the frame.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
haproxy (PTS)stretch1.7.5-2fixed
buster1.8.19-1+deb10u3fixed
buster (security)1.8.19-1+deb10u2fixed
bullseye (security), bullseye2.2.9-2+deb11u2fixed
bookworm, sid2.4.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
haproxysourcejessie(not affected)
haproxysourcestretch(not affected)
haproxysource(unstable)1.8.16-2

Notes

[stretch] - haproxy <not-affected> (Vulnerable code introduced later)
[jessie] - haproxy <not-affected> (Vulnerable code introduced later)
https://github.com/haproxy/haproxy/commit/a01f45e3ced23c799f6e78b5efdbd32198a75354

Search for package or bug name: Reporting problems