CVE-2018-20685

NameCVE-2018-20685
DescriptionIn OpenSSH 7.9, scp.c in the scp client allows remote SSH servers to bypass intended access restrictions via the filename of . or an empty filename. The impact is modifying the permissions of the target directory on the client side.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1728-1, DSA-4387-1
NVD severitylow (attack range: remote)
Debian Bugs919101

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssh (PTS)jessie1:6.7p1-5+deb8u4vulnerable
jessie (security)1:6.7p1-5+deb8u8fixed
stretch (security), stretch1:7.4p1-10+deb9u6fixed
buster, sid1:7.9p1-10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensshsource(unstable)1:7.9p1-5low919101
opensshsourcejessie1:6.7p1-5+deb8u8lowDLA-1728-1
opensshsourcestretch1:7.4p1-10+deb9u5lowDSA-4387-1

Notes

https://github.com/openssh/openssh-portable/commit/6010c0303a422a9c5fa8860c061bf7105eb7f8b2
https://sintonen.fi/advisories/scp-client-multiple-vulnerabilities.txt

Search for package or bug name: Reporting problems