CVE-2018-20760

NameCVE-2018-20760
DescriptionIn GPAC 0.7.1 and earlier, gf_text_get_utf8_line in media_tools/text_import.c in libgpac_static.a allows an out-of-bounds write because a certain -1 return value is mishandled.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1693-1
NVD severitymedium (attack range: remote)
Debian Bugs921969

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gpac (PTS)jessie0.5.0+svn5324~dfsg1-1vulnerable
jessie (security)0.5.0+svn5324~dfsg1-1+deb8u4fixed
stretch0.5.2-426-gc5ad4e4+dfsg5-3+deb9u1fixed
bullseye, sid, buster0.5.2-426-gc5ad4e4+dfsg5-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gpacsource(unstable)0.5.2-426-gc5ad4e4+dfsg5-4.1medium921969
gpacsourcejessie0.5.0+svn5324~dfsg1-1+deb8u2mediumDLA-1693-1
gpacsourcestretch0.5.2-426-gc5ad4e4+dfsg5-3+deb9u1medium

Notes

https://github.com/gpac/gpac/commit/4c1360818fc8948e9307059fba4dc47ba8ad255d
https://github.com/gpac/gpac/issues/1177

Search for package or bug name: Reporting problems