CVE-2018-20761

NameCVE-2018-20761
DescriptionGPAC version 0.7.2 and earlier has a Buffer Overflow vulnerability in the gf_sm_load_init function in scene_manager.c in libgpac_static.a.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs921969

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gpac (PTS)jessie0.5.0+svn5324~dfsg1-1vulnerable
jessie (security)0.5.0+svn5324~dfsg1-1+deb8u1vulnerable
stretch0.5.2-426-gc5ad4e4+dfsg5-3vulnerable
buster, sid0.5.2-426-gc5ad4e4+dfsg5-4vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gpacsource(unstable)(unfixed)medium921969

Notes

https://github.com/gpac/gpac/commit/35ab4475a7df9b2a4bcab235e379c0c3ec543658
https://github.com/gpac/gpac/issues/1186

Search for package or bug name: Reporting problems