CVE-2018-20847

NameCVE-2018-20847
DescriptionAn improper computation of p_tx0, p_tx1, p_ty0 and p_ty1 in the function opj_get_encoding_parameters in openjp2/pi.c in OpenJPEG through 2.3.0 can lead to an integer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1851-1
NVD severitymedium (attack range: remote)
Debian Bugs931294

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openjpeg2 (PTS)jessie2.1.0-2+deb8u3vulnerable
jessie (security)2.1.0-2+deb8u7fixed
stretch (security), stretch2.1.2-1.1+deb9u3vulnerable
bullseye, sid, buster2.3.0-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openjpeg2source(unstable)(unfixed)medium931294
openjpeg2sourcejessie2.1.0-2+deb8u7mediumDLA-1851-1

Notes

https://github.com/uclouvain/openjpeg/commit/5d00b719f4b93b1445e6fb4c766b9a9883c57949
https://github.com/uclouvain/openjpeg/issues/431
https://github.com/uclouvain/openjpeg/commit/c58df149900df862806d0e892859b41115875845

Search for package or bug name: Reporting problems