CVE-2018-20861

NameCVE-2018-20861
Descriptionlibopenmpt before 0.3.11 allows a crash with certain malformed custom tunings in MPTM files.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libopenmpt (PTS)stretch0.2.7386~beta20.3-3+deb9u3vulnerable
buster0.4.3-1fixed
bullseye, sid0.4.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libopenmptsource(unstable)0.3.11-1

Notes

[stretch] - libopenmpt <no-dsa> (Minor issue)
https://lib.openmpt.org/libopenmpt/2018/07/28/security-updates-0.3.11-0.2.10635-beta34-0.2.7561-beta20.5-p10-0.2.7386-beta20.3-p13/
https://source.openmpt.org/browse/openmpt/trunk/?op=revision&rev=10615 (0.3.11)
https://source.openmpt.org/browse/openmpt/trunk/?op=revision&rev=10616 (0.2.10635-beta34)
https://source.openmpt.org/browse/openmpt/trunk/?op=revision&rev=10617 (0.2.10635-beta34)

Search for package or bug name: Reporting problems