CVE-2018-20961

NameCVE-2018-20961
DescriptionIn the Linux kernel before 4.16.4, a double free vulnerability in the f_midi_set_alt function of drivers/usb/gadget/function/f_midi.c in the f_midi driver may allow attackers to cause a denial of service or possibly have unspecified other impact.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1fixed
jessie (security)3.16.76-1fixed
stretch4.9.189-3fixed
stretch (security)4.9.189-3+deb9u2fixed
buster4.19.67-2fixed
buster (security)4.19.67-2+deb10u2fixed
bullseye5.2.17-1fixed
sid5.3.9-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.16.5-1
linuxsourcejessie(not affected)
linuxsourcestretch4.9.107-1

Notes

[jessie] - linux <not-affected> (Vulnerability introduced later)
Fixed by: https://git.kernel.org/linus/7fafcfdf6377b18b2a726ea554d6e593ba44349f

Search for package or bug name: Reporting problems