CVE-2018-21010

NameCVE-2018-21010
DescriptionOpenJPEG before 2.3.1 has a heap buffer overflow in color_apply_icc_profile in bin/common/color.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs939553

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openjpeg2 (PTS)jessie2.1.0-2+deb8u3vulnerable
jessie (security)2.1.0-2+deb8u7vulnerable
stretch (security), stretch2.1.2-1.1+deb9u3vulnerable
bullseye, sid, buster2.3.0-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openjpeg2source(unstable)(unfixed)medium939553

Notes

https://github.com/uclouvain/openjpeg/commit/2e5ab1d9987831c981ff05862e8ccf1381ed58ea

Search for package or bug name: Reporting problems