CVE-2018-21017

NameCVE-2018-21017
DescriptionGPAC 0.7.1 has a memory leak in dinf_Read in isomedia/box_code_base.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs940855

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gpac (PTS)jessie0.5.0+svn5324~dfsg1-1fixed
jessie (security)0.5.0+svn5324~dfsg1-1+deb8u4fixed
stretch0.5.2-426-gc5ad4e4+dfsg5-3+deb9u1fixed
bullseye, buster, sid0.5.2-426-gc5ad4e4+dfsg5-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gpacsource(unstable)(not affected)
gpacsourceexperimental(unfixed)medium940855

Notes

- gpac <not-affected> (Vulnerable code introduced in 0.6.0)
https://github.com/gpac/gpac/issues/1183
Introduced in https://github.com/gpac/gpac/commit/6cfd65819add78426d9635e3f8358f8bc149b645 (v0.6.0)
Fixed by: https://github.com/gpac/gpac/commit/d2371b4b204f0a3c0af51ad4e9b491144dd1225c (v0.8.)

Search for package or bug name: Reporting problems