CVE-2018-21029

NameCVE-2018-21029
Descriptionsystemd 239 through 243 accepts any certificate signed by a trusted certificate authority for DNS Over TLS. Server Name Indication (SNI) is not sent, and there is no hostname validation with the GnuTLS backend.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
systemd (PTS)jessie215-17+deb8u7fixed
jessie (security)215-17+deb8u13fixed
stretch232-25+deb9u12fixed
stretch (security)232-25+deb9u11fixed
buster241-7~deb10u2vulnerable
bullseye, sid243-7vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
systemdsource(unstable)(unfixed)
systemdsourcejessie(not affected)
systemdsourcestretch(not affected)

Notes

[buster] - systemd <no-dsa> (Minor issue; systemd-resolved not enabled by default)
[stretch] - systemd <not-affected> (Vulnerable code introduced later)
[jessie] - systemd <not-affected> (Vulnerable code introduced later)
https://github.com/systemd/systemd/issues/9397

Search for package or bug name: Reporting problems