CVE-2018-21245

NameCVE-2018-21245
DescriptionPound before 2.8 allows HTTP request smuggling, a related issue to CVE-2016-10711.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pound (PTS)stretch2.7-1.3+deb9u1fixed
bullseye3.0-2fixed
bookworm, sid3.0.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
poundsourcejessie2.6-6+deb8u2
poundsourcestretch2.7-1.3+deb9u1
poundsource(unstable)2.8-2

Notes

https://admin.hostpoint.ch/pipermail/pound_apsis.ch/2018-May/000054.html
The exact scope of CVE-2018-21245 (a related issue to CVE-2016-10711) was
as well fixed with the same changes as done upstream for 2.8. The backport
for 2.7 was a backport of all security relevant changes between 2.7 and 2.8.
The same corrections were made in 2.6 version for jessie so fixed in that too.

Search for package or bug name: Reporting problems