CVE-2018-25009

NameCVE-2018-25009
DescriptionA heap-based buffer overflow was found in libwebp in versions before 1.0.1 in GetLE16().
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2677-1, DSA-4930-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libwebp (PTS)buster, buster (security)0.6.1-2+deb10u1fixed
bullseye0.6.1-2.1fixed
bookworm, sid1.2.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libwebpsourcestretch0.5.2-1+deb9u1DLA-2677-1
libwebpsourcebuster0.6.1-2+deb10u1DSA-4930-1
libwebpsource(unstable)0.6.1-2.1

Notes

https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=9100
https://chromium.googlesource.com/webm/libwebp/+/95fd65070662e01cc9170c4444f5c0859a710097%5E%21/

Search for package or bug name: Reporting problems