CVE-2018-25012

NameCVE-2018-25012
DescriptionA heap-based buffer overflow was found in libwebp in versions before 1.0.1 in GetLE24().
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2677-1, DSA-4930-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libwebp (PTS)buster0.6.1-2+deb10u1fixed
buster (security)0.6.1-2+deb10u3fixed
bullseye, bullseye (security)0.6.1-2.1+deb11u2fixed
bookworm, bookworm (security)1.2.4-0.2+deb12u1fixed
sid, trixie1.3.2-0.4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libwebpsourcestretch0.5.2-1+deb9u1DLA-2677-1
libwebpsourcebuster0.6.1-2+deb10u1DSA-4930-1
libwebpsource(unstable)0.6.1-2.1

Notes

https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=9123
https://chromium.googlesource.com/webm/libwebp/+/95fd65070662e01cc9170c4444f5c0859a710097%5E%21/

Search for package or bug name: Reporting problems