CVE-2018-25014

NameCVE-2018-25014
DescriptionA flaw was found in libwebp in versions before 1.0.1. An unitialized variable is used in function ReadSymbol. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2677-1, DSA-4930-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libwebp (PTS)stretch0.5.2-1vulnerable
stretch (security)0.5.2-1+deb9u1fixed
buster, buster (security)0.6.1-2+deb10u1fixed
bullseye, sid0.6.1-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libwebpsourcestretch0.5.2-1+deb9u1DLA-2677-1
libwebpsourcebuster0.6.1-2+deb10u1DSA-4930-1
libwebpsource(unstable)0.6.1-2.1

Notes

https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=9496

Search for package or bug name: Reporting problems