CVE-2018-25017

NameCVE-2018-25017
DescriptionRawSpeed (aka librawspeed) 3.1 has a heap-based buffer overflow in TableLookUp::setTable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
darktable (PTS)stretch2.2.1-3fixed
buster2.6.0-1fixed
bullseye3.4.1-5fixed
bookworm, sid3.6.1-1fixed
photoflow (PTS)bookworm, sid, bullseye0.2.8+git20200114-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
darktablesourcestretch(not affected)
darktablesource(unstable)2.6.0-1
photoflowsource(unstable)(not affected)

Notes

[stretch] - darktable <not-affected> (Vulnerable code added later)
- photoflow <not-affected> (Fixed before initial upload to the archive)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=5256
https://github.com/darktable-org/rawspeed/commit/dbe7591e54bad5e6430d38be6bed051582da76b9
https://github.com/google/oss-fuzz-vulns/blob/main/vulns/librawspeed/OSV-2018-227.yaml
darktable 2.6.0 is the first release to bundle rawspeed 3.2 with the fixes

Search for package or bug name: Reporting problems