CVE-2018-25045

NameCVE-2018-25045
DescriptionDjango REST framework (aka django-rest-framework) before 3.9.1 allows XSS because the default DRF Browsable API view templates disable autoescaping.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5186-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
djangorestframework (PTS)buster, buster (security)3.9.0-1+deb10u1fixed
bullseye3.12.1-1fixed
bookworm, sid3.14.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
djangorestframeworksourcebuster3.9.0-1+deb10u1DSA-5186-1
djangorestframeworksource(unstable)3.10.2-1

Notes

https://github.com/encode/django-rest-framework/commit/4bb9a3c48427867ef1e46f7dee945a4c25a4f9b8 (3.9.1)

Search for package or bug name: Reporting problems