CVE-2018-25047

NameCVE-2018-25047
DescriptionIn Smarty before 3.1.47 and 4.x before 4.2.1, libs/plugins/function.mailto.php allows XSS. A web page that uses smarty_function_mailto, and that could be parameterized using GET or POST input parameters, could allow injection of JavaScript code by a user.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1019896, 1019897

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
smarty3 (PTS)buster, buster (security)3.1.33+20180830.1.3a78a21f+selfpack1-1+deb10u1vulnerable
bullseye (security), bullseye3.1.39-2+deb11u1vulnerable
bookworm, sid3.1.45-1vulnerable
smarty4 (PTS)bookworm, sid4.1.1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
smarty3source(unstable)(unfixed)1019897
smarty4source(unstable)(unfixed)1019896

Notes

https://github.com/smarty-php/smarty/issues/454
https://github.com/smarty-php/smarty/commit/f1f7ee6e34c14a8a9dfa5c6ef894d39277a93938 (v3.1.47)
https://github.com/smarty-php/smarty/commit/55ea25d1f50f0406fb1ccedd212c527977793fc9 (v4.2.1)

Search for package or bug name: Reporting problems