CVE-2018-3064

NameCVE-2018-3064
DescriptionVulnerability in the MySQL Server component of Oracle MySQL (subcomponent: InnoDB). Supported versions that are affected are 5.6.40 and prior, 5.7.22 and prior and 8.0.11 and prior. Easily exploitable vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server as well as unauthorized update, insert or delete access to some of MySQL Server accessible data. CVSS 3.0 Base Score 7.1 (Integrity and Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1488-1, DSA-4341-1
NVD severitymedium (attack range: remote)
Debian Bugs904121

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mariadb-10.0 (PTS)jessie10.0.32-0+deb8u1vulnerable
jessie (security)10.0.37-0+deb8u1fixed
mariadb-10.1 (PTS)stretch10.1.26-0+deb9u1vulnerable
stretch (security)10.1.37-0+deb9u1fixed
buster1:10.1.37-1fixed
sid1:10.1.37-3fixed
mysql-5.7 (PTS)sid5.7.24-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mariadb-10.0source(unstable)(unfixed)medium
mariadb-10.0sourcejessie10.0.36-0+deb8u1mediumDLA-1488-1
mariadb-10.1source(unstable)1:10.1.35-1medium
mariadb-10.1sourcestretch10.1.37-0+deb9u1mediumDSA-4341-1
mysql-5.7source(unstable)5.7.23-1medium904121

Notes

MariaDB: Fixed in 10.0.36, 10.1.35

Search for package or bug name: Reporting problems