CVE-2018-3721

NameCVE-2018-3721
Descriptionlodash node module before 4.17.5 suffers from a Modification of Assumed-Immutable Data (MAID) vulnerability via defaultsDeep, merge, and mergeWith functions, which allows a malicious user to modify the prototype of "Object" via __proto__, causing the addition or modification of an existing property that will exist on all objects.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs890575

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-lodash (PTS)stretch4.16.6+dfsg-2vulnerable
buster4.17.11+dfsg-2+deb10u1fixed
bullseye4.17.21+dfsg+~cs8.31.173-1fixed
bookworm4.17.21+dfsg+~cs8.31.198.20210220-8fixed
sid4.17.21+dfsg+~cs8.31.198.20210220-9fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-lodashsource(unstable)4.17.11+dfsg-1unimportant890575

Notes

https://snyk.io/vuln/npm:lodash:20180130
https://github.com/lodash/lodash/commit/d8e069cc3410082e44eb18fcf8e7f3d08ebe1d4a
nodejs not covered by security support

Search for package or bug name: Reporting problems