CVE-2018-3847

NameCVE-2018-3847
DescriptionMultiple exploitable buffer overflow vulnerabilities exist in image parsing functionality of the CFITSIO library version 3.42. Specially crafted images parsed via the library, can cause a stack-based buffer overflow overwriting arbitrary data. An attacker can deliver an FIT image to trigger this vulnerability and potentially gain code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs892458

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cfitsio (PTS)jessie3.370-2+deb8u1vulnerable
stretch3.410-1vulnerable
buster, sid3.450-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cfitsiosource(unstable)3.430-1low892458

Notes

[stretch] - cfitsio <no-dsa> (Minor issue)
[jessie] - cfitsio <no-dsa> (Minor issue)
https://www.talosintelligence.com/vulnerability_reports/TALOS-2018-0530
double-check

Search for package or bug name: Reporting problems