CVE-2018-4088

NameCVE-2018-4088
DescriptionAn issue was discovered in certain Apple products. iOS before 11.2.5 is affected. macOS before 10.13.3 is affected. Safari before 11.0.3 is affected. iCloud before 7.3 on Windows is affected. iTunes before 12.7.3 on Windows is affected. tvOS before 11.2.5 is affected. watchOS before 4.2.2 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
webkit2gtk (PTS)buster2.36.4-1~deb10u1fixed
buster (security)2.38.0-1~deb10u1fixed
bullseye2.36.7-1~deb11u1fixed
bullseye (security)2.38.0-1~deb11u1fixed
bookworm, sid2.38.0-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
webkit2gtksourcestretch2.18.6-1~deb9u1
webkit2gtksource(unstable)2.18.6-1unimportant

Notes

https://webkitgtk.org/security/WSA-2018-0002.html
Not covered by security support

Search for package or bug name: Reporting problems