CVE-2018-5096

NameCVE-2018-5096
DescriptionA use-after-free vulnerability can occur while editing events in form elements on a page, resulting in a potentially exploitable crash. This vulnerability affects Firefox ESR < 52.6 and Thunderbird < 52.6.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1256-1, DLA-1262-1, DSA-4096-1, DSA-4102-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox-esr (PTS)jessie52.8.1esr-1~deb8u1fixed
jessie (security)68.3.0esr-1~deb8u1fixed
stretch60.7.1esr-1~deb9u1fixed
stretch (security)68.3.0esr-1~deb9u1fixed
buster68.2.0esr-1~deb10u1fixed
buster (security)68.3.0esr-1~deb10u1fixed
bullseye68.2.0esr-1fixed
sid68.3.0esr-1fixed
thunderbird (PTS)jessie1:52.8.0-1~deb8u1fixed
jessie (security)1:68.2.2-1~deb8u1fixed
stretch1:60.8.0-1~deb9u1fixed
stretch (security)1:68.2.2-1~deb9u1fixed
buster1:60.9.0-1~deb10u1fixed
buster (security)1:68.2.2-1~deb10u1fixed
bullseye1:60.9.0-1fixed
sid1:68.3.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefox-esrsource(unstable)52.6.0esr-1
firefox-esrsourcejessie52.6.0esr-1~deb8u1DSA-4096-1
firefox-esrsourcestretch52.6.0esr-1~deb9u1DSA-4096-1
firefox-esrsourcewheezy52.6.0esr-1~deb7u1DLA-1256-1
thunderbirdsource(unstable)1:52.6.0-1
thunderbirdsourcejessie1:52.6.0-1~deb8u1DSA-4102-1
thunderbirdsourcestretch1:52.6.0-1~deb9u1DSA-4102-1
thunderbirdsourcewheezy1:52.6.0-1~deb7u1DLA-1262-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2018-03/#CVE-2018-5096
https://www.mozilla.org/en-US/security/advisories/mfsa2018-04/#CVE-2018-5096

Search for package or bug name: Reporting problems