CVE-2018-5098

NameCVE-2018-5098
DescriptionA use-after-free vulnerability can occur when form input elements, focus, and selections are manipulated by script content. This results in a potentially exploitable crash. This vulnerability affects Thunderbird < 52.6, Firefox ESR < 52.6, and Firefox < 58.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1256-1, DLA-1262-1, DSA-4096-1, DSA-4102-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid82.0-1fixed
firefox-esr (PTS)stretch68.10.0esr-1~deb9u1fixed
stretch (security)78.4.0esr-1~deb9u1fixed
buster68.12.0esr-1~deb10u1fixed
buster (security)78.4.0esr-1~deb10u2fixed
bullseye78.3.0esr-2fixed
sid78.4.0esr-2fixed
thunderbird (PTS)stretch1:68.10.0-1~deb9u1fixed
stretch (security)1:78.3.1-2~deb9u1fixed
buster1:68.12.0-1~deb10u1fixed
buster (security)1:78.3.1-2~deb10u2fixed
bullseye1:68.12.0-1fixed
sid1:78.3.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)58.0-1
firefox-esrsourcewheezy52.6.0esr-1~deb7u1DLA-1256-1
firefox-esrsourcejessie52.6.0esr-1~deb8u1DSA-4096-1
firefox-esrsourcestretch52.6.0esr-1~deb9u1DSA-4096-1
firefox-esrsource(unstable)52.6.0esr-1
thunderbirdsourcewheezy1:52.6.0-1~deb7u1DLA-1262-1
thunderbirdsourcejessie1:52.6.0-1~deb8u1DSA-4102-1
thunderbirdsourcestretch1:52.6.0-1~deb9u1DSA-4102-1
thunderbirdsource(unstable)1:52.6.0-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2018-02/#CVE-2018-5098
https://www.mozilla.org/en-US/security/advisories/mfsa2018-03/#CVE-2018-5098
https://www.mozilla.org/en-US/security/advisories/mfsa2018-04/#CVE-2018-5098

Search for package or bug name: Reporting problems