CVE-2018-5148

NameCVE-2018-5148
DescriptionA use-after-free vulnerability can occur in the compositor during certain graphics operations when a raw pointer is used instead of a reference counted one. This results in a potentially exploitable crash. This vulnerability affects Firefox ESR < 52.7.3 and Firefox < 59.0.2.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1321-1, DSA-4153-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid94.0.2-1fixed
firefox-esr (PTS)stretch68.10.0esr-1~deb9u1fixed
stretch (security)78.15.0esr-1~deb9u1fixed
buster78.14.0esr-1~deb10u1fixed
buster (security)78.15.0esr-1~deb10u1fixed
bullseye78.14.0esr-1~deb11u1fixed
bullseye (security)78.15.0esr-1~deb11u1fixed
bookworm78.14.0esr-1fixed
sid91.3.0esr-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)59.0.2-1
firefox-esrsourcewheezy52.7.3esr-1~deb7u1DLA-1321-1
firefox-esrsourcejessie52.7.3esr-1~deb8u1DSA-4153-1
firefox-esrsourcestretch52.7.3esr-1~deb9u1DSA-4153-1
firefox-esrsource(unstable)52.7.3esr-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2018-10/

Search for package or bug name: Reporting problems