CVE-2018-5335

NameCVE-2018-5335
DescriptionIn Wireshark 2.4.0 to 2.4.3 and 2.2.0 to 2.2.11, the WCP dissector could crash. This was addressed in epan/dissectors/packet-wcp.c by validating the available buffer length.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)wheezy1.8.2-5wheezy18vulnerable
wheezy (security)1.12.1+g01b65bf-4+deb8u6~deb7u8vulnerable
jessie1.12.1+g01b65bf-4+deb8u11vulnerable
jessie (security)1.12.1+g01b65bf-4+deb8u12vulnerable
stretch2.2.6+g32dac6a-2vulnerable
stretch (security)2.2.6+g32dac6a-2+deb9u1vulnerable
buster2.4.3-1vulnerable
sid2.4.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)2.4.4-1

Notes

https://www.wireshark.org/security/wnpa-sec-2018-04.html
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=14251
https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=086b87376b988c555484349aa115d6e08ac6db07

Search for package or bug name: Reporting problems