CVE-2018-5379

NameCVE-2018-5379
DescriptionThe Quagga BGP daemon (bgpd) prior to version 1.2.3 can double-free memory when processing certain forms of UPDATE message, containing cluster-list and/or unknown attributes. A successful attack could cause a denial of service or potentially allow an attacker to execute arbitrary code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1286-1, DSA-4115-1
NVD severityhigh (attack range: remote)
Debian Bugs890563

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
quagga (PTS)jessie (security), jessie0.99.23.1-1+deb8u5fixed
stretch (security), stretch1.1.1-3+deb9u2fixed
buster, sid1.2.4-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
quaggasource(unstable)1.2.4-1high890563
quaggasourcejessie0.99.23.1-1+deb8u5highDSA-4115-1
quaggasourcestretch1.1.1-3+deb9u2highDSA-4115-1
quaggasourcewheezy0.99.22.4-1+wheezy3+deb7u3highDLA-1286-1

Notes

https://www.quagga.net/security/Quagga-2018-1114.txt
https://git.savannah.gnu.org/cgit/quagga.git/commit/?id=e69b535f92eafb599329bf725d9b4c6fd5d7fded

Search for package or bug name: Reporting problems