CVE-2018-5380

NameCVE-2018-5380
DescriptionThe Quagga BGP daemon (bgpd) prior to version 1.2.3 can overrun internal BGP code-to-string conversion tables used for debug by 1 pointer value, based on input.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1286-1, DSA-4115-1
NVD severitymedium
Debian Bugs890563

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
quagga (PTS)stretch (security), stretch1.1.1-3+deb9u2fixed
buster1.2.4-3fixed
sid1.2.4-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
quaggasourcewheezy0.99.22.4-1+wheezy3+deb7u3DLA-1286-1
quaggasourcejessie0.99.23.1-1+deb8u5DSA-4115-1
quaggasourcestretch1.1.1-3+deb9u2DSA-4115-1
quaggasource(unstable)1.2.4-1890563

Notes

https://www.quagga.net/security/Quagga-2018-1550.txt
https://git.savannah.gnu.org/cgit/quagga.git/commit/?id=9e5251151894aefdf8e9392a2371615222119ad8

Search for package or bug name: Reporting problems