CVE-2018-5381

NameCVE-2018-5381
DescriptionThe Quagga BGP daemon (bgpd) prior to version 1.2.3 has a bug in its parsing of "Capabilities" in BGP OPEN messages, in the bgp_packet.c:bgp_capability_msg_parse function. The parser can enter an infinite loop on invalid capabilities if a Multi-Protocol capability does not have a recognized AFI/SAFI, causing a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1286-1, DSA-4115-1
NVD severitymedium (attack range: remote)
Debian Bugs890563

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
quagga (PTS)jessie (security), jessie0.99.23.1-1+deb8u5fixed
stretch (security), stretch1.1.1-3+deb9u2fixed
buster, sid1.2.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
quaggasource(unstable)1.2.4-1medium890563
quaggasourcejessie0.99.23.1-1+deb8u5mediumDSA-4115-1
quaggasourcestretch1.1.1-3+deb9u2mediumDSA-4115-1
quaggasourcewheezy0.99.22.4-1+wheezy3+deb7u3mediumDLA-1286-1

Notes

https://www.quagga.net/security/Quagga-2018-1975.txt
https://git.savannah.gnu.org/cgit/quagga.git/commit/?id=ce07207c50a3d1f05d6dd49b5294282e59749787

Search for package or bug name: Reporting problems