CVE-2018-5390

NameCVE-2018-5390
DescriptionLinux kernel versions 4.9+ can be forced to make very expensive calls to tcp_collapse_ofo_queue() and tcp_prune_ofo_queue() for every incoming packet which can lead to a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1466-1, DSA-4266-1
NVD severityhigh (attack range: remote)
Debian Bugs905751

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1fixed
jessie (security)3.16.59-1fixed
stretch4.9.110-1vulnerable
stretch (security)4.9.110-3+deb9u6fixed
buster, sid4.18.10-2fixed
linux-4.9 (PTS)jessie (security)4.9.110-3+deb9u5~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.17.14-1high905751
linuxsourcejessie(not affected)
linuxsourcestretch4.9.110-3+deb9u1highDSA-4266-1
linux-4.9sourcejessie4.9.110-3+deb9u2~deb8u1highDLA-1466-1

Notes

[jessie] - linux <not-affected> (Vulnerable code introduced later)
https://www.kb.cert.org/vuls/id/962459

Search for package or bug name: Reporting problems