CVE-2018-5729

NameCVE-2018-5729
DescriptionMIT krb5 1.6 or later allows an authenticated kadmin with permission to add principals to an LDAP Kerberos database to cause a denial of service (NULL pointer dereference) or bypass a DN container check by supplying tagged data that is internal to the database module.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1643-1
NVD severitymedium (attack range: remote)
Debian Bugs891869

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
krb5 (PTS)jessie1.12.1+dfsg-19+deb8u4vulnerable
jessie (security)1.12.1+dfsg-19+deb8u5fixed
stretch1.15-1+deb9u1vulnerable
buster, sid1.17-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
krb5source(unstable)1.16.1-1medium891869
krb5sourcejessie1.12.1+dfsg-19+deb8u5mediumDLA-1643-1

Notes

[stretch] - krb5 <no-dsa> (Minor issue)
[wheezy] - krb5 <no-dsa> (Minor issue)
Fixed by: https://github.com/krb5/krb5/commit/e1caf6fb74981da62039846931ebdffed71309d1

Search for package or bug name: Reporting problems