CVE-2018-5733

NameCVE-2018-5733
DescriptionA malicious client can overflow a reference counter in ISC dhcpd
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1313-1, DSA-4133-1
Debian Bugs891785

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
isc-dhcp (PTS)jessie (security), jessie4.3.1-6+deb8u3fixed
stretch4.3.5-3vulnerable
stretch (security)4.3.5-3+deb9u1fixed
buster, sid4.3.5-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
isc-dhcpsource(unstable)4.3.5-3.1891785
isc-dhcpsourcejessie4.3.1-6+deb8u3DSA-4133-1
isc-dhcpsourcestretch4.3.5-3+deb9u1DSA-4133-1
isc-dhcpsourcewheezy4.2.2.dfsg.1-5+deb70u9DLA-1313-1

Notes

https://kb.isc.org/article/AA-01567/75/CVE-2018-5733
https://bugs.isc.org/Public/Bug/Display.html?id=47140
https://source.isc.org/cgi-bin/gitweb.cgi?p=dhcp.git;a=commit;h=197b26f25309f947b97a83b8fdfc414b767798f8 (4.4.1)
Fixes for 4.3.6p1: https://source.isc.org/cgi-bin/gitweb.cgi?p=dhcp.git;a=commit;h=99a25aedea02d9c259cb8fabf4be700fb32571a3

Search for package or bug name: Reporting problems