CVE-2018-5759

NameCVE-2018-5759
Descriptionjsparse.c in Artifex MuJS through 1.0.2 does not properly maintain the AST depth for binary expressions, which allows remote attackers to cause a denial of service (excessive recursion) via a crafted file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mujs (PTS)bullseye1.1.0-1+deb11u1fixed
bookworm, sid1.2.0-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mujssource(unstable)(not affected)

Notes

- mujs <not-affected> (Fixed before initial upload to Debian)
http://git.ghostscript.com/?p=mujs.git;a=commit;h=4d45a96e57fbabf00a7378b337d0ddcace6f38c1
https://bugs.ghostscript.com/show_bug.cgi?id=698868

Search for package or bug name: Reporting problems