CVE-2018-5950

NameCVE-2018-5950
DescriptionCross-site scripting (XSS) vulnerability in the web UI in Mailman before 2.1.26 allows remote attackers to inject arbitrary web script or HTML via a user-options URL.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1272-1, DSA-4108-1
NVD severitymedium (attack range: remote)
Debian Bugs888201

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mailman (PTS)wheezy1:2.1.15-1+deb7u1vulnerable
wheezy (security)1:2.1.15-1+deb7u3fixed
jessie1:2.1.18-2+deb8u1vulnerable
jessie (security)1:2.1.18-2+deb8u2fixed
stretch (security), stretch1:2.1.23-1+deb9u2fixed
buster, sid1:2.1.26-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mailmansource(unstable)1:2.1.26-1medium888201
mailmansourcejessie1:2.1.18-2+deb8u2mediumDSA-4108-1
mailmansourcestretch1:2.1.23-1+deb9u2mediumDSA-4108-1
mailmansourcewheezy1:2.1.15-1+deb7u3mediumDLA-1272-1

Notes

https://mail.python.org/pipermail/mailman-users/2018-February/083011.html
Patch: https://launchpadlibrarian.net/355686141/options.patch
https://bugs.launchpad.net/mailman/+bug/1747209

Search for package or bug name: Reporting problems