CVE-2018-6484

NameCVE-2018-6484
DescriptionIn ZZIPlib 0.13.67, there is a memory alignment error and bus error in the __zzip_fetch_disk_trailer function of zzip/zip.c. Remote attackers could leverage this vulnerability to cause a denial of service via a crafted zip file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs889089

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
zziplib (PTS)jessie (security), jessie0.13.62-3+deb8u1vulnerable
buster, sid, stretch0.13.62-3.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zziplibsource(unstable)(unfixed)medium889089

Notes

[stretch] - zziplib <no-dsa> (Minor issue)
[jessie] - zziplib <no-dsa> (Minor issue)
[wheezy] - zziplib <ignored> (Minor issue)
https://github.com/gdraheim/zziplib/issues/14

Search for package or bug name: Reporting problems